How can we help you today?
Start a new topic

M65 Handsets not receiving calls on M700 multicell network

Dear all

I recently upgraded a perfectly working M700 multicell network from two bases to three bases. There are 7 M65 handsets. I had to bring the M700 units to the latest 510.1 Firmware version because of mismatch. 

I also had to reset all units and reassign primary role to the newer unit.

After the upgrade the handsets randomly stop receiving calls despite good signal. They can make calls with no problems. If turned off and on, they will get incoming calls for like a hour or so, and then nothing.

I imagined a firmware mismatch, so I upgraded all handsets to the same 510.1 firmware but it didn't solve the problem.

Below the multicell and the handsets situation. Oddly no handset is registering to the primary (RPN00) station despite being in range.

Any suggestions?

With regards

Niccolo Gallarati

(92.4 KB)
(52.3 KB)


Questo sembra un problema giá riportato per l'utilizzo del nostro ultimo firmware con l'ultima versione di 3CX, le apriró un ticket sul nostro portale e risponderó lí direttamente. 

I have the exact same issue with M900 multicell running 510 firmware and 5 m80 handsets


Please try a downgrade to firmare 501.1 for the base stations: if it still doesn't work please raise a private ticket with us and we'll investigate.

Thank you

I confirm same issue: phones appear as registered but they are unreachable. Firmware Cell 510.1, Phone 510.2, mixed multicell (multi primary M700, with some M900 as secondary) and Phones M25/M65. Now trying to downgrade cells only to 501.1

I can confirm that downgrading base stations to 501.1 apparently fixed the issue (36 hours without failures...)

For your record, we are still using the phones already upgraded to 510.1.

Waiting for fixed firmware...


I can confirm that we are working to solve this issue with 3CX in our future firmware, thank you for reporting back to us on this.


Just wanted to say that this also happens with Yeastar PBX's. Will downgrade the M700 later today to see if it solves.


Thank you for letting us know, I'll adjust the notes on our firmware page and update the developers, I suspect that's because a good part of Yeastar and 3CX are quite similar to be honest

The downgrade to version 501.1 for the bases and 501.2 for the handsets seem to have solved the issue.



You had to downgrade the handsets? Just the bases wasn't enough?

Snom says the bases downgrade is enough, however I preferred to have everything on the same page. I believe there should be a correlation between base and handset firmware, as they are part of a single release

I have the same issue with placetel PBX. Will also try a downgrade to 501.1 and 501.2.

we have the same problem freePBX 7xM700 and 47x M65. In addition I can't register any more m65 on the m700.

I tried to downgrade the base from 510.1 to 501.1

Login or Signup to post a comment