How can we help you today?
Start a new topic

VTech VH621 HD handset stuck on "Out of Range?"

 

To preface, I doubt this is the right subreddit for this, if anyone has any suggestions for where this post should go I will post there and take this down.


I recently got a Snom D717 desk phone at my office. I was given permission to take a VTech VH621 headset off a different phone we have since it wasn't being used. It was paired to a Snom A230 DECT dongle. I took the dongle and connected it to my new desk phone. However, the headset now just beeps once every 20 seconds or so and says "Out of Range", and nothing I try gets it to reset or deregister.

Things I've tried:

  1. Deregistering the dongle, both in the old and new phone.

  2. Removing the battery from the headset for a few seconds and reconnecting it.

  3. Following the normal setup process and leaving it sit for around 5 minutes.

At this point, I don't see any way to reset the actual headset, despite resetting the dongle 5+ times. No matter what I try, all it does is say "Out of range."

Again, I apologize, as I know this is very likely the wrong sub for this, but I can't find any help or additional instructions from either Snom or Vtech, and I couldn't find a dedicated subreddit for either of those brands, so I posted this here. Our phone system is 3CX at least, if that makes a difference.

Thanks in advance!

EDIT: I called VTech, and their solution is below. This was not publicly available, I had to call them for them to provide this info. I think it's an annoying business practice to not publish simple support items like this and force people to sit through being on hold with phone support, so I figure I'll save some people some heartache and post these instructions:

In order to completely factory reset the headset and get it back into pairing mode, press and release rapidly the keys in the following order:

  1. Vol+

  2. On/Power

  3. Vol-

  4. On/Power

  5. Vol+

  6. Vol-

  7. On/Power

At this point, the headset should be in pairing mode with the Power button flashing red and blue slowly. Proceed to pair like normal.

1 Comment

Hi,


Thank you for the update and the edit on the original post, this is something more to do with the Vtech product and while I understand your frustration for not finding these info online, I am glad it was solved by contacting Vtech directly.


Have a nice day

Login or Signup to post a comment