How can we help you today?
Start a new topic

Numberkeys don't send DTMF

Hardware: snomD385
Firmware: snomD385-SIP 10.1.33.35

possible solutions won't work:
- setting "Identity 1-SIP-DTMF via SIP INFO" values " = "off", "on" or "SIP INFO only"
- setting "Identity 1-RTP-Full SDP Answer" = "on"
- setting "Identity 1-RTP-RTP Encryption" = "off"

unacceptable workaround:
setting Line Keys Page 4 to Type "DTMF" and Number per Key "0","1","2","3","4","5","6","7","8","9","*","#"


any solutions for "Standard"-DTMF-Functionality.


best Regard, Dirk

1 Comment

Dirk,


Is the problem that DTMF stops working after a period of time or that you suspect DTMF is not sent either inband or out of band? Could you upgrade to the latest firmware release candidate 10.1.39.11 and consult the below information.


https://service.snom.com/display/wiki/10.1.39.11+Release 




What kind of DTMF types do Snom phone support and how to change them?


Default type


The DTMF type is negotiated during the call setup. By default, the Snom phones use RFC 2833 out-of-band DTMF type. To do this, it sends the following message inside the INVITE message SDP body:


a=fmtp:101 0-15 

where:


fmtp is the OOB (out of band RFC 2833) offer 101 example payload ID 0-15 defines the range of keys: 0-11 (12) normal keyboard + 4 letters "abcd" If the receiver accepts out-of-band, the SIP 200 OK response may contain the following in the SDP section:

a=fmtp:101 0-11 

Note: If this message is absent, RFC 2833 is disabled and the Snom phone assumes that in-band DTMF must be used. Depending on the abilities of the two parties, "out-of-band (OOB)" is certainly preferable and "in-band" should be used as fallback only.


Changing the DTMF type


You can change the DTMF type as follows:


Dedault: RFC 2833 is used

To enable SIP INFO additionally to RFC 2833, you can set "DTMF via SIP INFO" to "on"

To enable SIP INFO only, you can set "DTMF via SIP INFO" to "sip_info_only"

To force in-band DTMF: set "DTMF via SIP INFO" to "off", and under phone -> Identity 1 -> RTP remove "telephone-event" from the Codec List.


Regards,


Snom Support

Login or Signup to post a comment