How can we help you today?
Start a new topic
Answered

XML Definitions and states does not work

Hello Dear Snom Team,

 

I try to use the states in XML Definitions (function key).

It works when I not use the states. But I would also like to make use of these possibilities.

 

 

 

So what I am doing wrong? How can I verify that the NotifyParsingRules works?

 

 

 

1234567e999@sipgate.de is my sipgate ID on Identity 1 and works.

 

 

 

As I said when removing states='calling,in_a_call,offhook,free,ringing' it works.

 

 

 

My XML looks like this:

 

 

 

<general type="BusyLampField" identity="1"/>

<initialization>

    <variable name="subscr_uri" value="sip:1234567e999@sipgate.de"/>

</initialization>

 

<subscription type="dialog" to="&lt;$(subscr_uri)&gt;" for="$(subscr_uri)"/>

 

<NotifyParsingRules type="applies">

    <level1 translates_to='OK'>/dialog-info[@entity="$(subscr_uri)"]</level1>

</NotifyParsingRules>

 

<NotifyParsingRules type="state">

    <level1 translates_to="ringing">/dialog-info/dialog/state[.="early"]</level1>

    <level1-1 translates_to="calling">/dialog-info/dialog[@direction="initiator"]</level1-1>

    <level2 translates_to="ringing">/dialog-info/dialog/state[.="proceeding"]</level2>

    <level2-1 translates_to="calling">/dialog-info/dialog[@direction="initiator"]</level2-1>

    <level3 translates_to="in_a_call">/dialog-info/dialog/state[.="confirmed"]</level3>

    <level4 translates_to="offhook">/dialog-info/dialog/state[.="trying"]</level4>

    <level5 translates_to="free"/>

</NotifyParsingRules>

<NotifyParsingRules type="variable" id="call_id" state="ringing">

    <level1 fetch_attribute="call-id">/dialog-info/dialog[@call-id]</level1>

</NotifyParsingRules>

<NotifyParsingRules type="variable" id="remote_tag" state="ringing">

    <level1 fetch_attribute="remote-tag">/dialog-info/dialog[@remote-tag]</level1>

</NotifyParsingRules>

<NotifyParsingRules type="variable" id="local_tag" state="ringing">

    <level1 fetch_attribute="local-tag">/dialog-info/dialog[@local-tag]</level1>

</NotifyParsingRules>

<NotifyParsingRules type="variable" id="remote_uri" state="ringing">

    <level1 fetch_attribute="uri">/dialog-info/dialog/remote/target[@uri]</level1>

</NotifyParsingRules>

<NotifyParsingRules type="variable" id="remote_name" state="ringing">

    <level1 fetch_attribute="display">/dialog-info/dialog/remote/identity[@display]</level1>

</NotifyParsingRules>

<action>

 <url target="http://142.121.18.9/dummy.htm?settings=save&fwd_all_target1=1234567" when="on press" states='calling,in_a_call,offhook,free,ringing'/>

</action>



Best Regards


Best Answer

The issue is solved by chnaging subscr_uri from SIP_ID@sipgate.de to internal_extention_number@sipgate.de.
Thanks Magnar for sharing the solution. 


Best regards

snom support team


Answer

The issue is solved by chnaging subscr_uri from SIP_ID@sipgate.de to internal_extention_number@sipgate.de.
Thanks Magnar for sharing the solution. 


Best regards

snom support team

I am testing on a snomD375-10.1.37.11

Dear Magnar,

I guess in the initialization tag you have to define the state like seen under this link:
http://docs.snom.io/xml_definitions/#xml_definitions


best regards

snom support team

Login or Signup to post a comment