How can we help you today?
Start a new topic

Snom D785 loses the user pictures of the identities after a reboot

I've set user photos for the various identities on our Snom D785. When the phone restarts, these pictures are lost.


The same happens if I set the value "Settings Refresh Timer" (Advanced> Update) not equal to '0'


Firmware is the newest version 10.1.33.33.


Is it a firmware problem? Or can someone give me a tip, which I can do better?


thanks Joerg


Jorg,


Are you adding these images via the Web UI of the phone manually to the Identity? What format and resolution are your images? Are you using provisioning on the phone?  I just tried to reproduce this and was unable to.


1. Added a jpeg image with resolution of 480x480 to Identity 1 on D785 with version 10.1.33.33 firmware

2. Rebooted phone via Advanced > Update > Reboot

3. Image appeared on LCD for Identity 1 after reboot



Am I using the same workflow as you?


Regards,


Snom Support

Hello,

I proceed as follows:

1. Added a jpeg image with resolution of 480x480 to Identity 1 on D785 with version 10.1.33.33 firmware with web ui

2. Added a jpeg image with resolution of 480x480 to Identity 2 with web ui

3. Rebooted phone via Advanced> Update> Reboot

4. No pictures available, everything back to standard Picture reset

 

After a restart, the phone also loses the settings for color and opacity of the display.

 

What can I do?


thanks Joerg

Jorg,


Try adjusting your image to 150x150 pixels and save it as a .png image. I have this working on my D785 (10.1.33.33).


Regards,



Snom Support

Hi Sean,

Unfortunately, the problem persists.

Images in the format 150x150 png are lost with a reboot.

 

We have a total of three snom D785 and the problem persists.

We would like to buy more devices, but first the problem must be solved.


And, as I have already written, there is also the problem that set colors and opacity for the display are lost with a reboot.


thanks Joerg

Jorg,


Are you, or have you, used any type of provisioning on these phones? Possibly the permissions flags in the settings are set to allow changes, but they are overwritten/lost on reboot/re-provisioning.



Features/Mass Deployment/Setting Files/XML/Flags

< Features | Mass Deployment | Setting Files | XML

Flags are defined as "permission flags" in the string "perm" within XML tags. Valid values are:

NOTE: If administrators want to be able to overwrite user parameter definitions, they need to use perm="$". With perm="!", the settings can be changed by mass provisioning only if the end user has not made changes to the configuration on the phone itself or on its web interface.
  • perm="&" or perm="R" or perm=" ": The configuration parameters are Read Only and cannot be changed by the end user.
  • perm="$" or perm="RW" or perm="" The configuration parameters can be changed by the end user but will be overwritten by mass provisioning.




Regards,


Snom Support




Hi Sean,

not that I know. 

I have set the setting URL to automatically accept a global phone book.

Is it possible that I send you my settings by eMail?


regards Joerg

Jorg,


I just replied to you via email.



Regards,



Snom Support

Hello!


I have the same problem, because I also set the setting URL to automatically accept a global phone book. But this function seems to overwrite always the settings for the Identity pictures, too. If I disable the setting URL to automatically accept a global phone book. It works, but is could not be the solution. Isn't it possible to update only the global phone book instead of all settings?


Kind regards

Tim

Tim,


When you add a profile picture for a users Identity/SIP account on the phone a corresponding entry is created in the local directory. The local directory is the place holder for the image you added to the Identity


image #1



image #2



Directory XML


<tbook e="2">

<item context="" type="" fav="false" mod="true" index="4">

<number>1234@PBX.example.com</number>

<number_type>sip</number_type>

<photo_filename>38854a935dad616aecd6771bd38816d419083926.png</photo_filename>

<birthday>00/00/99</birthday>

</item>

</tbook>


If you are writing a new directory to the phone and it does not contain the extension and the  <photo_filename>38854a935dad616aecd6771bd38816d419083926.png</photo_filename>  that would explain why. Possibly the provisioned directory/phone book is overwriting the phone's local directory.

Login or Signup to post a comment