How can we help you today?
Start a new topic
Answered

Veeery slow input behaviour on LDAP query Snom D785 (10.1.20.0)

 Hi,


attached you will find a mp4 which shows the behaviour of a Snom D785 phone if I try to find a name in our LDAP.


If I push the LDAP-Button and try to search for an entry, in this case "lip", I push the buttons for the chars (3*5=L, 3*4=i, 1*7=p). For this I need approximately 3 seconds. After this you can see that the phone needs approximately 7 seconds to "build" the three chars on the display. The query itself seems to be very fast (approximately 1 to 2 seconds).


My LDAP filters and attributes are configured with the following lines:

[...]
<ldap_search_filter perm="R">(&(|(cn=%)(sn=%))(|(otherIpPhone=*)(ipPhone=*)))</ldap_search_filter>
<ldap_number_filter perm="R">(|(otherIpPhone=%)(ipPhone=%))</ldap_number_filter>
<ldap_name_attributes perm="R">sn displayName givenName</ldap_name_attributes>
<ldap_number_attributes perm="R">otherTelephone otherMobile telephoneNumber Mobile ipPhone</ldap_number_attributes>
<ldap_display_name perm="R">%sn, %givenName</ldap_display_name>
[...]

 

It seems that the phone after each push of a button querys the LDAP and waits for a response. Is this correct?


If so, I would have a suggestion for improvement: Wait 500ms (or a second) after a button push before you send out the LDAP request. If in the meanwhile a new button is pushed don't send the LDAP request and wait again the defined time. If no button is pushed in the defined time than send the LDAP request. Many Users are very fast in pushing the buttons to find the right entry.


Thanks in advance


Marcus

mp4

Best Answer

Hi Marcus,


This issue is known and has been improved a lot in our latest firmware update. Can you please upgrade your phone and tell us what you think?


https://service.snom.com/display/wiki/10.1.33.33


Thanks

Catalina



Answer

Hi Marcus,


This issue is known and has been improved a lot in our latest firmware update. Can you please upgrade your phone and tell us what you think?


https://service.snom.com/display/wiki/10.1.33.33


Thanks

Catalina


Hi Catalina,


Thank you for the Information and your help.


I applied the new Firmware (10.1.33.33) to one of my phones and tested it. Now the interface seems to be faster but it does not find any results in my directory. Also I have first to change the edit mode from numbers to chars. It's not very comfortable.


Tomorrow I will investigate more and give a response.


Only by the way. I liked the old WebUI better. I miss the links to help for each attribute and the font was clearer. The underlined hyperlinks in the navigation are unnecessary. The simple hyperlinks from before have kept the menu a bit clearer.

Are the new features documented already? Can you give me a hint for the functions in "Identity->Features->Directory Download". That sounds interesting.


Thanks

Marcus

Hi Marcus,


regarding the web-interface: did you try re-loading the page / pages without browser cache? Typically it is CTRL / strg and F5 key . This might "repair" your web UI-experience, at least partially.


Thanks,

Jan

Hi Jan,


Yes, I've already tried that. But I think it's the font itself.

But at the moment the solution of the LDAP problems is more important to me. It's a show stopper.

I will investigate it and open a new case.


Thanks and greetings from Charlottenburg.

Marcus

Hi,


there is an error in the new firmware. The LDAP search request is missing asterisks for an incomplete search. I created a Ticket #18089.


Greetings
Marcus

Hi Jan,


regarding the web-interface: Although Ctrl + F5 did not solve the problem, deleting cached web content from Firefox helped. Now the WebUI looks really nice. Thank you.


Greetings

Marcus

Hi Marcus,


Since you asked about documentation, some of the features are documented here:

https://service.snom.com/display/wiki/FW+V10+-+Features

https://service.snom.com/display/wiki/GUI+-+Customisation


Thanks

Catalina

Login or Signup to post a comment