How can we help you today?
Start a new topic
Answered

D785 - user_pic not transfered to called party

Hi,


I provisioned our Snom D785 phones (Firmware 10.1.20.0) with the following options. The picture is changed on every phone.

<with_flash perm="!">on</with_flash>
<user_pic idx="1" perm="RW">http://<serverIP>/picture/user1.jpg</user_pic>
<prefer_saved_over_received_photo perm="!">off</prefer_saved_over_received_photo>

The picture is shown on my "Home"-Screen for the identity. But if I call a colleague the picture is not shown on the called phone.


In the SIP trace on my phone I can see that the picture is mentioned in the "Call-Info"-Line in the INVITE process. 


If I upload the same picture in the local directory of every phone the picture will be shown. But I need the opportunity to auto provision the picture information and I found no XML parameter to do that in the tbook segment of my provisioning file or to automatic load the CSV file.


Nevertheless i prefer the way to save the picture in my http server and let receive the phones it from there.

Can anybody give me some advice which option I missed?


Thanks in advance


Best Answer

Hi Catalina,


the Server has edited the SIP messages. My Source SIP included the information but the destination not.

Now I have resolved this issue with my LDAP Querys. My LDAP included all the pictures of my colleagues and now the pictures are received from there.


Thank you very much for your advice.


Marcus


Hi Marcus,


Can you check the SIP trace on the receiving phone? Is the Call-Info header still there? Some servers edit the SIP messages before sending them to the destination.


I installed the same version as you on two test phones, reset all settings to default, configured only the basic SIP account and the 3 settings like you posted. In my case it worked, both phones showed each other's picture when calling. Maybe you can try the same (with factory reset to make sure no other setting is affecting your test)?


Thanks

Catalina


Answer

Hi Catalina,


the Server has edited the SIP messages. My Source SIP included the information but the destination not.

Now I have resolved this issue with my LDAP Querys. My LDAP included all the pictures of my colleagues and now the pictures are received from there.


Thank you very much for your advice.


Marcus

Login or Signup to post a comment