How can we help you today?
Start a new topic
Answered

Dhcp option 12 not being sent?

 I have both 710 and 720 handsets running V8.9.3.80


For some reason they are no longer sending dhcp option 12 (hostname)



Here is an example from tcpdump


23:21:23.788323 IP (tos 0x0, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 361)
    0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, Request from 00:04:13:76:27:19 (oui Unknown), length 333, xid 0x3829b40d, Flags [none] (0x0000)
          Client-Ethernet-Address 00:04:13:76:27:19 (oui Unknown)
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            Parameter-Request Option 55, length 14:
              Subnet-Mask, Default-Gateway, Time-Server, Domain-Name-Server
              Hostname, Domain-Name, NTP, Vendor-Option
              Lease-Time, FQDN, Option 120, Option 125

              Option 132, Option 133
            Vendor-Class Option 60, length 7: "snom710"
            FQDN Option 81, length 14: [S] "snom710-553"
            T125 Option 125, length 30: 0,3561,6401,1584,12336,13361,13058,1591,13874,14129,14595,1907,28271,27959,12592
            Agent-Information Option 82, length 14:
              Circuit-ID SubOption 1, length 4: ^A,^@^N
              Remote-ID SubOption 2, length 6: dfM-3M-#M-iM-^@
            END Option 255, length 





I cannot find any config option that seems to control it. The v7 series firmware had no such problems on nearly identical config


Best Answer

It seems that the option 81 "overwrites" option 12. I could reproduce in the lab that if you activate option 81, option 12 will get deactivated. 


Do you need option 81? if not, please remove it from the setting dhcp_options_on_ip_aquire .


Let me know if this solves the problem.


Thanks

Catalina



Hi Dean,


Sorry for the delay. There is a setting that my help here: http://wiki.snom.com/Settings/dhcp_options_on_ip_aquire . Option 12 is on by default.


I just tested with 710 and version 8.9.3.80, after factory reset (to make sure all configuration is default) it sent option 12 in the DHCP discovery:


Bootstrap Protocol (Discover)
    Message type: Boot Request (1)
    Hardware type: Ethernet (0x01)
    Hardware address length: 6
    Hops: 0
    Transaction ID: 0xad03d087
    Seconds elapsed: 0
    Bootp flags: 0x0000 (Unicast)
    Client IP address: 0.0.0.0
    Your (client) IP address: 0.0.0.0
    Next server IP address: 0.0.0.0
    Relay agent IP address: 0.0.0.0
    Client MAC address: SnomTech_74:2a:21 (00:04:13:74:2a:21)
    Client hardware address padding: 00000000000000000000
    Server host name not given
    Boot file name not given
    Magic cookie: DHCP
    Option: (53) DHCP Message Type (Discover)
    Option: (55) Parameter Request List
    Option: (60) Vendor class identifier
    Option: (12) Host Name
        Length: 14
        Host Name: snom710-742A21

    Option: (125) V-I Vendor-specific Information
    Option: (255) End

I would therefore recommend that you check setting http://wiki.snom.com/Settings/dhcp_options_on_ip_aquire or factory reset the phone and try again.


I hope this helps.


Thanks

Catalina


This is my current setting:

<dhcp_options_on_ip_aquire perm="">1 3 4 6 12 15 42 43 51 81 120 125 132 133</dhcp_options_on_ip_aquire>

 

Hi Dean,


Can you please do a factory reset and see if it solved the problem? If it still doesn't work please get a PCAP Trace from the DHCP request and I will open a ticket for you to send it privately for me to check.


Thanks

Catalina


after factory reset the option 12 is present. however once the config file i loaded it is no longer sent.

here is the config file saved from the phone
(attached)

 

xml
(77.9 KB)
Answer

It seems that the option 81 "overwrites" option 12. I could reproduce in the lab that if you activate option 81, option 12 will get deactivated. 


Do you need option 81? if not, please remove it from the setting dhcp_options_on_ip_aquire .


Let me know if this solves the problem.


Thanks

Catalina


thats fixed it, thanks

 

Login or Signup to post a comment