How can we help you today?
Start a new topic
Answered

PA-1 Multicast Priorities not working

I have found that multicast stream priority does not work with the PA-1. I guess this is the reason why:


From the SNOM wiki:


"Starting at version 8.7.3.26 you can setup the multicast address with additional options":


....among which is:


  • priority=(0..10):
This option sets the priority of the multicast address. You can choose a priority between 0 and 10, where 0 is the lowest and 10 the highest priority. If the phone receives multicast from more than one configured port, then the multicast with the highest priority will be played.
Unfortunately the latest firmware, which I already have, is
snom PA1-SIP 8.7.3.25.

Looking at the setting.xml file, none of the the additional multicast settings. are even present, just the addresses.

Any suggestions?


Best Answer

Hi John,


>But, when I make a SIP call to the PA-1, the multicast stream often mutes, but with no audio on the voice call. Other times it  works OK. And other times I hear a broken-up  mix of both sources...


This is a bug (internal IDs: SCPP-7283, SCPP-7284) and we are working on it. Until we have a fix, you can try a workaround to configure the phone to disable multicast whenever a call is connected and enable  it again when the call gets disconnected. For this:
 -go to Action URL 

-under "On Connected:" enter "127.0.0.1/dummy.htm?settings=save&multicast_listen=off" 

-under "On Disconnected:" enter "127.0.0.1/dummy.htm?settings=save&multicast_listen=on" 

-Save


Note: if the phone has a http username/password you need to enter them too: 

-under "On Connected:" enter "http://user:password@127.0.0.1/dummy.htm?settings=save&multicast_listen=off

-under "On Disconnected:" enter "http://user:password@127.0.0.1/dummy.htm?settings=save&multicast_listen=on"


We have had customers report that the bug does not occur on 8.7.3.25, can you please check?


Thanks

Catalina



OK, as I searched, I found progressively newer firmwares, ending up with snomPA1-SIP 8.7.5.75. And multicast priorities do work. I can make multicast pages from a yealink phone that override a lower-priority continuous music stream.


But, when I make a SIP call to the PA-1, the multicast stream often mutes, but with no audio on the voice call. Other times it works OK. And other times I hear a broken-up  mix of both sources...



 

 

Answer

Hi John,


>But, when I make a SIP call to the PA-1, the multicast stream often mutes, but with no audio on the voice call. Other times it  works OK. And other times I hear a broken-up  mix of both sources...


This is a bug (internal IDs: SCPP-7283, SCPP-7284) and we are working on it. Until we have a fix, you can try a workaround to configure the phone to disable multicast whenever a call is connected and enable  it again when the call gets disconnected. For this:
 -go to Action URL 

-under "On Connected:" enter "127.0.0.1/dummy.htm?settings=save&multicast_listen=off" 

-under "On Disconnected:" enter "127.0.0.1/dummy.htm?settings=save&multicast_listen=on" 

-Save


Note: if the phone has a http username/password you need to enter them too: 

-under "On Connected:" enter "http://user:password@127.0.0.1/dummy.htm?settings=save&multicast_listen=off

-under "On Disconnected:" enter "http://user:password@127.0.0.1/dummy.htm?settings=save&multicast_listen=on"


We have had customers report that the bug does not occur on 8.7.3.25, can you please check?


Thanks

Catalina


 Thanks for responding.I ended up using 8.7.5.44 which seems to work better.

Login or Signup to post a comment