How can we help you today?
Start a new topic
Answered

Snom PA1 Multicast stops after few minutes

Hi,

I am having a problem when I multicast after a few minutes it stops. I am using FFmpeg to cast to the snom. I'm using a yealink phone to cast the intercom to the phone (on a different port). after a few minutes, the FFmpeg  multicast stops working while the yealink still works


I'm using the latest firmware.



I'm using this FFmpeg commend

 

ffmpeg -re -i "%%A" -filter_complex "aresample=16000,asetnsamples=n=160,volume=-23dB" -acodec g722 -ac 1 -vn -f rtp udp://239.255.255.245:5556)

 or 

ffmpeg -re -i "%%A" -filter_complex "aresample=8000,asetnsamples=n=160,volume=-23dB" -acodec pcm_mulaw -ac 1 -vn -f rtp udp://239.255.255.245:5556)

 I Attached the settings to a txt file. also, I attach a trace pcap.


also, i have to reboot after changing any multicast IP. otherwise, it doesn't work









txt
(37.3 KB)
pcap

Best Answer

Jacob,


The forum posting you referenced points to someone trying to configure the reserved 'all hosts' Multicast address 224.0.0.1. It can be used for testing, but it's not intended to be used in a production environment. 224.0.0.0 is reserved. The valid range of multicast addresses in the administratively scoped IP version 4 (IPv4) multicast address space is the range from 239.0.0.0 through 239.255.255.255. 


Please refer to RFC 5771 to see the reserved Multicast addresses  https://tools.ietf.org/html/rfc5771 


See also https://www.iana.org/assignments/multicast-addresses/multicast-addresses.xhtml


Regards,


Sean Collins

Snom Support




Answer

Jacob,


The forum posting you referenced points to someone trying to configure the reserved 'all hosts' Multicast address 224.0.0.1. It can be used for testing, but it's not intended to be used in a production environment. 224.0.0.0 is reserved. The valid range of multicast addresses in the administratively scoped IP version 4 (IPv4) multicast address space is the range from 239.0.0.0 through 239.255.255.255. 


Please refer to RFC 5771 to see the reserved Multicast addresses  https://tools.ietf.org/html/rfc5771 


See also https://www.iana.org/assignments/multicast-addresses/multicast-addresses.xhtml


Regards,


Sean Collins

Snom Support



Jacob,


You're using 224.0.0.0 as a multicast address for your "Intercom" call? Why are you using 224.0.0.0? This address is not available for use.


https://www.iana.org/assignments/multicast-addresses/multicast-addresses.xhtml



Regards,



Sean Collins

Snom Support



Exactly.. 

I forget to mention, this is my second device, I bought this because I thought the device become defective, but I having the same issue.. I think something on the network do that but I can't figure what's wrong.

A Few months before it did work like a charm..


Ps. All settings are on the xml.txt


Here are the advance mullticast settings.


 

mc_address1!: ip=239.255.255.245:5556,speaker=0,interrupt=0,volmax=0,priority=2,name=Page Zone A
mc_address2!: ip=224.0.0.0:5555,speaker=0,interrupt=0,volmax=0,priority=9
mc_address3!: 
mc_address4!: 
mc_address5!: 
mc_address6!: 
mc_address7!: 
mc_address8!: 
mc_address9!: 
mc_address10!: 

 

Jacob,


"I setup the highest priority for the intercom" Do you mean you have a Multicast listener address configure in the Advanced > SIP/RTP section of the PA1 for both the audio stream and the intercom?



Regards,


Sean Collins

Snom Support


1 person likes this
Thanks Sean for the reply. Yes.. but I setup the highest priority for the intercom. Also it crashed before I even used the intercom

Jacob,


Are you streaming a multicast with FFmpeg and an Intercom to the PA1 at the same time?



Regards,



Sean Collins

Snom Support


1 person likes this
Login or Signup to post a comment