How can we help you today?
Start a new topic
Answered

XML Idle Screen URL D765 wrong file-format2 ?

Dear Miss, Mister   


I am using a SNOM D765 with the Firmware v8.9.3.80, I like to know, when I have downloaded the XML- file snom820/821_idlescreen.xml on http://wiki.snom.com/Category:HowTo:Background_Image

and I read the complete article on this webpage.

This photo result into a good background image on my D765.

But when I use my own xml-file (test_idleScreen.xml) this results into a black screen. 


In Setup,Identity 1,  Login, Login Information:  XML Idle Screen URL : http://192.168.151:80/local/viewer/snom821_idlescreen.xml


Both XML-files  I have included in the file-attachments and the seperated image (test.bmp).

Are there specific requirements for these xml-files ? 

I have used the preferred tools on the webpage.


Can anybody help with this please ?   

Kind Regards,  Vincent

bmp
(225 KB)
xml
xml

Best Answer

Hello Vincent,


Here is a working version of your idle screen, although you'll have to adjust your background image, since the text font is displayed in white on white. 

It's a new file I made, but in yours, I can see that the data tag is not closed properly. 


Best regards,


xml
(13.3 KB)

Hello Vincent,


In current 8.9.3.x firmwares, there is a much simpler way of putting a background image on the phones. 


You can just put a URL to the (png) image into this setting:

http://wiki.snom.com/Settings/custom_bg_image_url

It can also be set via the web interface in the general preferences page. 

The phone will download it and display it below your custom picture-less idle screen definition.


Best regards,

Dear Matthieu,


Thanks for the answer, Mhh, you confuse me.  The behaviour of the different background images, are depended if you use the url where a image can be choosen or by using the XML which has the image included. See also my other topic. I have include two photo's:

The photo called SNOM_D765_Background_XML is used when I use XML feature and represents the really background image on the device in idle state.


The other photo called SNOM_D765_Background_URL is used when I get the horn from the hook or when I choose an function key.  

These are completed different in behaviour and are seperated, can you confirm or explain this to me ?

For both topics which I have made, I have troubles about the exact format,  could you test these files and analyze why are those are not working, this will help me a lot.

Thanks in advance,


Best Regards,

Vincent 

 

Hello,


You are right, this new option doesn't do exactly the same, as it also changes the background image in other screens. 


As for your XML file, could you try converting your picture to a Jpeg one, again encoded to base64. The D765 supports both BMP and Jpeg but the resulting file will be much lighter and should work better. 


Thanks,

Hello Matthieu,


This didn't work also with a bmp or a jpg file, I really appreciate I you just want to investigate my files.

So I know what really is the cause of this problem/issue.


Regards,

Vincent

Answer

Hello Vincent,


Here is a working version of your idle screen, although you'll have to adjust your background image, since the text font is displayed in white on white. 

It's a new file I made, but in yours, I can see that the data tag is not closed properly. 


Best regards,


xml
(13.3 KB)

Hello Matthieu,


Thanks for the help, it works ok now,

But is it possible to change the color text of the date, time, identity name, or can this only besolved, by choosing another background color in my image instead of the white color ?

To get the best image quality, are all png, bmp, jpg formats supported in the xml file ?

Is it right that I have used in the XML-file :


/Data>   instead </DATA> and that was the misstake why it was not working ?

 

Best regards,

Vincent




Login or Signup to post a comment