How can we help you today?
Start a new topic

720: Update from 8.7.3.25.5 to 8.9.3.60 corrupts install

We have several 720 that I recently updated from 8.7.5.35 to 8.9.3.60 without problems. One phone was still on 8.7.3.25.5 because of a bug in 8.7.5.35 that was critical for that user. 

Several attempts to update that last phone allways led to various functions not working anymore. But the first sign that something went wrong was the not updated WUI (it still shows the colourful one with the lines and version number in the header).


Faulty functions I observed:

- Subscriptions messed up / missing

- Independet transfers fail

- Incoming calls: when call is picked up caller side is not being connected, ringing continues


- I installed 8.9.3.60 via WUI.

- I also reset the phone and reloaded the settings from XML-Config or configured them by hand.

- I downgraded to 8.7.3.25.5.

- I installed 8.9.3.60 also via **## Recue-Mode


Finally I reverted back to 8.7.3.25.5. This was the only version that I could get to work.


I still prefer to have the security fixes the current version provides.


So, what to do?


Have you tried an incremental upgrade from 8.7.3.25.5 > 8.7.5.35 > 8.9.3.60 on the one phone since you know going from 8.7.5.35 to 8.9.3.60 worked with six of the phones?

Hi Sean,


no, that I haven't tried yet. The release notes don't mention any requirements. But given the state of the wiki I probably shouldn't expect too much. Thanks for the suggestion. I'll come back with the outcome.

Tried the update from 8.7.3.25.5 to 8.7.5.35 as suggested. Does not lead to updated Web-UI and also immediately corrupts subscriptions. Wonder what's going on.

 

Possibly there is corruption in the flash memory. You could do a TFTP factory upgrade to 8.9.3.60 and see if that resolves the issue with the single 720.


https://helpdesk.snom.com/solution/articles/6000071238-how-to-reset-a-desktop-phone-to-the-factory-defaults-via-network-recovery

Thanks Sean for coming back on this. I tried the TFTP-Factory upgrade. Didn't help.


I actually tried this before, but used HTTP protocl. So just to be super safe, this time I used TFTP. Made no difference.


Do you have another idea?

Guido,


I converted this to a ticket. You should have received an email notification.


Regards,


Support

Login or Signup to post a comment