How can we help you today?
Start a new topic
Answered

6 second delay before placing call - NAPTR and SRV lookups even when disabled.

Hi,


We have a problem with some D715s running 8.9.3.60.


When a call is dialed, there is a 6 second delay before the handsets place the call. The logs show:


May 23 15:36:10.515 [ERROR ] PHN: No reply for naptr lookup
May 23 15:36:13.669 [ERROR ] PHN: No reply for srv lookup

We were advised to set:

dns_a_queries_only=on

which according to http://wiki.snom.com/Settings/dns_a_queries_only should solve the problem.


Changing the registrar from a FQDN to an IP address does remove the delay, but I really would rather provision a server name rather than address.


Any ideas?


Cheers,

Nicholas.


Best Answer

Hello,


Can you please try our latest release and check if this solves the problem? The release includes the fix for SCPP-7711


https://service.snom.com/display/wiki/10.1.33.33


Thanks

Catalina



Dear Nicholas,


thanks for contacting us,


If the DNS query takes so long usually is because the firewall is silently dropping the DNS requests (or the DNS server doesn't answer), so the phone waits for the connection timeout.


Isn't clear to me if dns_a_queries_only=on solved your issue or not..

Can you articulate a bit more ?

Hi same problem here

Jun 10 10:13:19.886 [ERROR ] PHN: No reply for naptr lookup
Jun 10 10:13:23.086 [ERROR ] PHN: No reply for srv lookup

 with dns_a_queries_only=on by provisioning


DNS is responding without issue, but dns_a_queries_only=on looks no have effects.


I'm testing it on snom 785 and 765 with latest firmware.

@Nicholas Have you found a solution?

Regards

Walter

Hi Walter and Nicholas,


the issue with dns_a_queries_only has been fixed (internal ID #SCPP-7711).


If you want we can provide you a beta version to test via a support ticket,

Yes please, very appreciate!


W.

Same Problem here with D385.


Shouldnt it has been fixed in the D385 Release Firmware?

Please also provide a Beta for Testing.

Answer

Hello,


Can you please try our latest release and check if this solves the problem? The release includes the fix for SCPP-7711


https://service.snom.com/display/wiki/10.1.33.33


Thanks

Catalina


Login or Signup to post a comment