How can we help you today?
Start a new topic
Answered

Snom 760 : let's encrypt ssl cert

Hello


using firmware snom760-SIP 8.7.5.35


It seems my let's encrypt certificate is not recognized/accepted.


When I use tls connection I get message on the screen that an unknown certificate was offered, and I need to manually add an exception (Setup > Certificates > Unknown Certificates)


My configuration : 

registrar : test.domain.be

Outbound proxy : test.domain.be:5061;transport=tls


My certificate :



Version: 3 (0x0002)

Serial Number: 032192c5d238af8e9844fb596f552a98f27f

Signature Algorithm: sha256WithRSAEncryption

Signature: 89d1b03c04f22314b4f18af6b6c90ae4e03c69e987b29870be2bdbc5c9ff15be96c310805d75c814...

Issuer: CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US

Validity: 10.05.2017 07:11:00 - 08.08.2017 07:11:00

SHA1-Fingerprint: d71c5e6fa75bb72aee5ce770ff2379d079fc212d

MD5-Fingerprint: 3aface5577a99ca7ce84c51aaccb900a

PK Algorithm: rsaEncryption

RSA modulus: 00E58BEA746FBE826D4A56EBDDBE3381E665DC578A9C0F8FD5C50DAA77732A4FD1AEEA8D5FA3FD8D...

RSA exponent: 65537 (0x10001)

I need to click 'Add exception'.

Why is my let's encrypt certificate not accepted as valid authority ?

And then after adding it to 'Server Certificates' tls registration still does not work. On my Asterisk server I see :

[May 10 11:02:42]   == Problem setting up ssl connection: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate

Can you tell me what is wrong with my certificate ?

Thanks.

Best Answer

You can find answers to most of your questions here;


http://wiki.snom.com/Category:HowTo:TLS


This message in on your Asterisk Server "[May 10 11:02:42]   == Problem setting up ssl connection: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate" are there any logs from the phone indicating a problem after you add the exception?

1 Comment

Answer

You can find answers to most of your questions here;


http://wiki.snom.com/Category:HowTo:TLS


This message in on your Asterisk Server "[May 10 11:02:42]   == Problem setting up ssl connection: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate" are there any logs from the phone indicating a problem after you add the exception?

Login or Signup to post a comment