How can we help you today?
Start a new topic
Answered

Long SIP-Contact (RFC3840) XML BUG!

I found a bug, when using the following withing my settings.xml:

<user_descr_contact idx="1" perm="">off</user_descr_contact>

Along with:

<user_server_type idx="1" perm="">asterisk</user_server_type>


The Long SIP-Contact (RFC3840) parameter is not changed to "off", it remains set to "on" position.  Try uploading the following to the phone via the Advanced > Update > Upload Setting File manually: parameter:

<settings>
<phone-settings e="2">
<user_descr_contact idx="1" perm="">off</user_descr_contact>
<user_server_type idx="1" perm="">asterisk</user_server_type>
</phone-settings>
</settings>

Confirmed on a Snom 760 running firmware:

Firmware-Version: snom760-SIP 8.7.5.44

and a Snom D765 running firmware:

Firmware-Version: snomD765-SIP 8.9.3.59.102

Best Answer
Hi, you are right, in this sequence is not possible.

Cause: changing the
user_server_type to asterisk will also revoke the change on the user_descr_contact.


I would suggest to change first the user_server_type and then the user_descr_contact! This will work.

<settings>
<phone-settings e="2">
<user_server_type idx="1" perm="">asterisk</user_server_type>
<user_descr_contact idx="1" perm="">off</user_descr_contact>
</phone-settings>
</settings>


Best regards

Sidaty
1 Comment

Answer
Hi, you are right, in this sequence is not possible.

Cause: changing the
user_server_type to asterisk will also revoke the change on the user_descr_contact.


I would suggest to change first the user_server_type and then the user_descr_contact! This will work.

<settings>
<phone-settings e="2">
<user_server_type idx="1" perm="">asterisk</user_server_type>
<user_descr_contact idx="1" perm="">off</user_descr_contact>
</phone-settings>
</settings>


Best regards

Sidaty
Login or Signup to post a comment