How can we help you today?
Start a new topic

Snom D765 & Plantronics Voyager Legend

I have a D765 with firmware 8.9.3.57. I like it and it took me a long time to get the thing working, went through several USB WiFi adapters to find one that worked, but have it set up and working. 


The reason I went with this device was its bluetooth headset support and the fact that I would be able to (with some messing about) get it working via WiFI.


But now I'm very frustrated. The bluetooth works, for a bit, then disconnects and refuses to reconnect to my headset. Usually I have to reboot the phone or unpair the headset and then pair it again. 


On more than one occasion I've been using the headset on a call that has lasted around an hour, had to release the call for whatever reason (usually knowing there'll be another call immediately following) and hear the dreaded "Phone x disconnected" from the headset. Knowing I have no chance of getting the phone to see the headset again I have to quickly launch the soft phone on my iPad or laptop before the next call comes in. 


Am I missing something? Is there anything I can do? Or do I have to get a different phone and go through the fun stuff all over again?


You could try using this firmwarehttp://wiki.snom.com/Firmware/V8_9_3_59_102


No idea if it will make a difference or not, bluetooth has always been very flakey on the D765 to date.

Also, http://wiki.snom.com/Accessories/Headset/Approved_Headsets states that Plantronics Voyager Legend is an approved BT headset. The documentation informs users that it was tested and approved using firmware version 8.7.5.35.


You could try downgrading your firmware to 8.7.5.35 and see if that helps.

Generally unsure about installing a pre-release firmware that contains absolutely no information in the release notes... I wonder how much testing is actually done, though, as the headset works, but then simply disconnects and does not connect again until I reboot the phone.


I'm going to try the RC FW, I can always drop back if it goes badly.

Hi Pete


If you are having troubles with bluetooth please open a helpdesk ticket and we could follow up there


As Paul Norman mentioned if you can test with latest firmware it would be great


Regards

Tried the latest FW and it seemed to work. But just now I've come off a call and it's disconnected me. Same routine.

 

did you try to upgrade your Legend firmware?


http://www.plantronics.com/us/support/myheadset/updater/legacy/


Regards

Login or Signup to post a comment