How can we help you today?
Start a new topic

XML Dial Plan Issues

Hi,


I have the following line within my snom XML dial plan file: 

<template match="##..." timeout="0" scheme="sip" user="phone" rewrite="" />

I need users to be able to dial numbers such as ##200, ##201 etc without delay. Unfortunately this doesn't appear to work at all. How does one add calls or short code dialling starting with a # to the XML dial plan?


I do have the following at the end of my XML dial plan: 

<template match="*" timeout="10" scheme="sip" user="phone" rewrite="" />

Which works once I remove the line containing the ##... but with a 10 second delay. I can add the use of calls and short codes beginning with * by using \* but why can't I do the same with the # key?


I'm using a Snom D765 running snomD765-SIP 8.9.3.59.102.


Ok so the use of # in a dial plan always results in making the phone dial a number when the pound key is pressed. I also had:

<template match="\*0#[2-8].." timeout="0" scheme="sip" user="phone" rewrite="" />

When dialling *0#, the call is placed without allowing the user to finish entering the remaining three digits.


Why doesn't Snom make use of something like \# which could be used to allow users to add numbers and short codes beginning with # or using a # within them to the dial plan? Similar to the existing * and \* implementation.

Dear Paul


We use regex expressions


Maybe you already saw http://wiki.snom.com/Features/Dial_Plan/Regular_Expressions


As an idea this regex expression maybe could fit in your requirements


^\*0#+[2-8]..


I recommend to test expression with for example


https://regex101.com/


Regards

Unfortunately regex doesn't allow the use of a timeout.


It's also unfortunate that Snom only allow the use of either XML dial plans or regex expressions, you cannot simply add ^\*0#+[2-8].. to the dial plan parameter within the identity sip tab because doing so results in anything else within the XML dial plan not working.

 

I posted this previously: http://forum.snom.com/index.php?showtopic=12488

 

It's a shame, Snom need to add the ability to add a timeout to the regex expressions, fix the XML dial plan rewrite rule and allow the use of # dialling.

Thanks Paul


I will open a develop internal request  and let you know back

Several years on and still no fix?

Also Rewrite does NOT work via XML Dialplan.


But via Regex it is still not possible ti use another identity. Combination of XML and Regex also does not work. If Regex is present, XML is no longer active...

Did you not read my post above? I posted the following link: http://forum.snom.com/index.php?showtopic=12488


Clearly Snom have no intention of fixing any of these issues.

Hello,


This request (cannot use # in the xml dialplan match) is in our bug tracking system with ID SCPP-8776. Unfortunately, the option to use # has not been implemented yet.


We apologize for the delay. Our development has many requests and it is always a challenge to prioritize them. If you would like to discuss your business case and request for a higher priority I would recommend to contact your Snom sales representative.


I have one suggestion that you could try here: if you set Auto Dial to 2 seconds for example, any number you type will be dialed faster so you don't have the 10 seconds-delay for numbers such as ##200 . See http://wiki.snom.com/Settings/auto_dial


Thanks

Catalina


Login or Signup to post a comment