How can we help you today?
Start a new topic

Firmware Upgrading on m300 / m25 (m325)

 Hello Forum,

I'm experiencing difficulty upgrading the m300 basestations as well as the added m25 phones on m325 packs.

I'm following this wiki:

Using an example instance, I entered the following in

Address of Firmware Server:

Firmware Directory: <empty>

I left the m25 fields blank for now as I want to upgrade the base stations first.

Required Version: 324

I currently have

IPDECT/03.23/B0012/11-Dez-2014 11:14

Now if I click ok, pretty much nothing happens - the box reboots, which takes only seconds, then its still the old Firmware Version.

If I do the same for 355, the box blinks orange for about 13 minutes and then reboots, however the old Firmware is still installed.

I also tried "0324", with no effect. It asks me "Are you sure you want to upgrade the Basestation to Version 0324?"
The webui then tells me that "The changes were saved successfully. You will be reconnected in three seconds". I'm translating the messages from a german webui btw.
It seems the firmware update is started minutes? after klicking "ok". In this time, we didnt do anything - might not be related to sbd using a handset.


We now managed to upgrade a basestation to IPDECT/03.55/B0021/05-Jul-2016 14:15.
We are now facing trouble upgrading the associated handset. Its version shown on the handset itself is Version 03.23 Branch 0012.

We tried the upgrade with "324", "0324", "0324" Branch "12", also with Branch "0012", but nothing seems to happen to the handset (even after some minutes). The syslog says:

loc3 .Info  2017-03-15T19:13:12Z 173-[ VoIP Number of configurations parsed: 6]
loc3 .Info  2017-03-15T19:13:12Z 173-[ DECT Number of configurations parsed: 0]

but no action seems to be taken on the m25 handset. We made sure the handset was in the loading station at all time and was not doing any calls or such. We restarted the handset and the basestation also once or twice, with no effect.

Hi Peter

You should be able to upgrade headsets from any firmware version to latest 355B21 (We recently released B22)

Please configure as shown

I recommend you also to enable syslog to DEBUG mode to see http request. Maybe you are getting any error when downloading headset firmware. 


Login or Signup to post a comment