How can we help you today?
Start a new topic
Answered

Update fails (320 v 8.7.5.17 to current)

 Hi


when I use the firmware update function and put in the url to the current firmware

http://downloads.snom.com/fw/snom320-8.7.5.35-SIP-f.bin

Firefox, Chromium and IE tell me at first, that the secure connection failed. (on german, so I can´t tell you the correct englisch message.)

On second try I get a plain html page, sounding like:

"there was a not authorized HTTP POST request to the phone. The session would be closed and you need to login again."

This is wrong. I don´t need to login again, I can just continue the session and configure the phone.


Even if I try to get the firmware via hattps: it doesn´t work out:

https://downloads.snom.com:80/fw/snom320-8.7.5.35-SIP-f.bin


I already uploaded the firmware to my own server to use this as source with the same effect.


What´s wrong?

Is there a different way to upload the current Firmware?


Greetings
Al


Best Answer
Hi,
I think this is known issue in previous version,
this is how you can solve it:
please disable the following setting: -> Setup -> Advanced -> QoS/Security -> Use hidden tags
You then should be able to access all items in the webinterface.

BR

 


I just clicked on the first link in your pose in Firefox and was able to download the firmware file so it looks like the link is working.

 

Answer
Hi,
I think this is known issue in previous version,
this is how you can solve it:
please disable the following setting: -> Setup -> Advanced -> QoS/Security -> Use hidden tags
You then should be able to access all items in the webinterface.

BR

 

That worked, thank you, Sidaty!


I wonder:

- shouldn´t the update work anyway? Isn´t this a security issue?

- it would be nice to get this notification in the GUI, or the option to disable this in the update function. Currently it´s not a valid solution for the users.


For further reference, the option is called either "Sicherheitshinweise ignorieren" or "Versteckte Merkmale" in german. Turn both off for update.


Hi,
The issue has been solved in the current version 8.7.5.44.
http://wiki.snom.com/Firmware/V8_7_5_44

 

Login or Signup to post a comment