How can we help you today?
Start a new topic
Answered

Upgrade to 8.7.x: Registrar: allow port number

Since firmware 8.7 it does no longer seem to be allowed to have a port number specified in the Identity -> "Registrar" field. At least an upgrade from 8.4.x to 8.7.x changes all identities registrar addresses when they contain a port number: user_host1!: user-host1-illegal-host-port user_host2!: user-host2-illegal-host-port user_host3!: user-host3-illegal-host-port user_host4!: user-host4-illegal-host-port user_host5!: user-host5-illegal-host-port user_host6!: user-host6-illegal-host-port user_host7!: user-host7-illegal-host-port user_host8!: user-host8-illegal-host-port Please allow identities to specify the port number. And supply a better upgrade path when the specified port is the default port number 5060 (just strip the :5060)-part.

Best Answer
"user user_outbound" this was a typo! Sorry.

I meant: the setting "user_outbound" In the Webuser interface it called "Outbound Proxy"

This will force the phone to send all SIP packets via the specified communication point with the specified transport protocol.

example:

user_outbound=bluesip.net:5060;transport=udp


I don't see this change in the release notes, this is causing provisioning to fail with many pbx systems, the provisioning templates in many pbx systems for years generated host.domain.com:5060;transport=udp which is now being replaced with user-host1-illegal-host-port we have been downgrading firmware for the paths few months.


2 people like this

 Hello

Its normal for me to use the (Outbound) Proxy for addressing purpose.

Example
Several AVM Fritz!Box in a lokal network...
First one (a dsl router)
Registrar: fritz.box
Proxy: 192.168.178.1:5060


Second one (an ip-client)

Registrar: fritz.box

Proxy: 192.168.178.2:5060
Hi Jacob,
sorry for the delayed answer.
AFAIK the change has been made starting from the firmware branch 8.7.5.x.
Thank you for pointing us to the link error. This has been corrected now.

BR
Sidaty

 


1 person likes this
In firmware 8.7.3.25.9 the port and protocol specification in the "Registrar:" (WUI) is still possible.

I have read the Snom firmware change log for 8.7.4 and 8.7.5. In none of the 2 documents is this change documented. Neither can I find the change at http://wiki.snom.com/Firmware/V8/Release_Notes

Would you please dissect the firmware revision number, since which firmware version the change has been made that port numbers and protocol specifications are no longer allowed in
user_host1!:

 a.k.a. "Registrar:" in the web user interface (WUI)?


---

Note: there is a link error at http://wiki.snom.com/Snom370/Firmware/V8 which points text "Change Log
8.7.5.35
" to the change log for 8.7.3 (http://wiki.snom.com/Firmware/V8/Release_Notes/Change_Log_V8_7_3)


Answer
"user user_outbound" this was a typo! Sorry.

I meant: the setting "user_outbound" In the Webuser interface it called "Outbound Proxy"

This will force the phone to send all SIP packets via the specified communication point with the specified transport protocol.

example:

user_outbound=bluesip.net:5060;transport=udp


1 person likes this
To be precise: http://downloads.snom.com:80/fw/snom370-8.7.3.25.9-SIP-f.bin is the old firmware.
I will try to upgrade to the April 2016 release: http://downloads.snom.com/fw/mru-preview/snom370-8.7.5.44-SIP-f.bin
Result: That upgrade also did change the "Registrar:" field to:
user-host1-illegal-host-port

 

 

The original (before firmware 8.7.x upgrade) value for the field "Registrar:" was like:
bluesip.net:5060;transport=udp

 There is a need to explicitly make sure that the Snom phone uses the udp protocol.

---

I don't understand what you do want me to do with the suggestion "user user_outbound", or is that a field name that is only available in 8.7.35 firmware and not in 8.7.3?


To be clear: my issue is that the firmware upgrade breaks the values that were previously configure in the various identities "Registrar:" fields.

 

You do not add i.e. transport=tcp to the Registrar. You add only the port number? 


Please try to use user_outbound with port number instead of registrar.

We have a customer where the configuration of user_outbound solves his issue.

8.7.5.35
http://downloads.snom.com/fw/snom370-8.7.5.35-SIP-f.bin

from http://wiki.snom.com/Firmware/V8/Release_Notes#Snom_3-series

 which 8.7.x is installed on the phones?


BR

Login or Signup to post a comment