How can we help you today?
Start a new topic
Answered

SNOM760-SIP Provisionning server failed

Greetings Support,


I have made a lot of research on this issue but wasn't able to find something which solved it.


The issue here being that our SNOM760-SIP phones are showing the "Provisioning server failed" error message on their screen.


What I tried doing to solve this issue was first to delete options 66 and 67 from the Advanced -> Network -> Options on DHCP:on on the phones.


I also tried disabling provisioning by changing the Advanced -> Update -> Update Policy value to "Never update, do not load settings", to no avail.


I get no error message in our TFTP provisioning server (which we use only for other phones, not our SNOMs, since we configure them manually because each of them has different configurations from the others).


Phone Type: snom760-SIP


Firmware-Version: snom760-SIP 8.7.5.13


Is it a known issue which would be fixed in recent Firmware version ?


Let me know if you need more informations and thanks in advance,

Carl


Best Answer

Hello,


I guess you have to disable the http://wiki.snom.com/wiki/index.php/Settings/restrict_uri_queries setting.


Also another configuration you can apply to skip the requests to provisioning.snom.com is removing the redirection entry from the provisioing_order (http://wiki.snom.com/Settings/provisioning_order).


you can do it in the same way:


"http://phone_IP/settings.htm?settings=save&provisioning_order=pnp:stop dhcp:stop tr69:stop"


 Hi,


could you try the latest version 8.7.5.35

1) Ist the phone being provisioned? Usually the phone by default tries to contact provisioning.snom.com in order to see if there is any redirection being set up. If for some reason the phone cannot access the server you will get the error message.

If you are not interested in resolving the actual cause you can also have the phones configured to not show this error.
This can be achieved by removing the value "PhoneProvisioningFailed" from these three phone settings:

http://wiki.snom.com/Settings/status_msgs_that_show_directly
http://wiki.snom.com/Settings/status_msgs_that_are_essential
http://wiki.snom.com/Settings/status_msgs_that_are_important


Greeting

Thank you for the reply,

The phone isn't being provisionned. I configure it manually through the web interface since the configuration informations cannot be dynamized (unique for each phones). We have provisioning/autoconfigurations for other models, just not the SNOMs.


I will try the firmware update but seeing your explanation, I don't think that will solve the issue since it's probably trying to reach the provisioning.snom.com server, but being installed on a local, closed network, it cannot reach it and displays the error message.

Modifying the 3 settings you mention would seem like an acceptable workaround for this issue. I told the person the message is not to be worried about but he doesn't like having it. I'm currently connected to the phone in the "Settings" screen and I see the value "PhoneProvisiningFailed" that you mention ... but should I be able to modify those through the web interface ? I'd think so but haven't found how to do so ?

Hi, 

ok. you are right the update would not slove the issue: "since it's probably trying to reach the provisioning.snom.com server, but being installed on a local, closed network, it cannot reach it and displays the error message."

But will solve others. :). I would suggest it.

>>>should I be able to modify those through the web interface ? I'd think so but haven't found how to do so?

The mentioned setting can't be changed on the web user interface. Use either provisioning or HTTP GET requests in order to change thiem. For the latter you would need to enter the following URL in a browser

http://phoneIP/dummy.htm?settings=save&{setting_name}={changed new_value}. Without { }.


Thanks again for the reply, this is a command which will be very useful !


That said, do I have to change settings/preferences for it to be functional ? I'm trying to send the following GET Request:

 

http://192.168.21.11/dummy.htm?settings=save&status_msgs_that_show_directly=CallBackOnBusyInProgress%20CallBackOnBusyAvailable%20PhoneProvisioningStarting%20PhoneProvisioningInProgress%20PhoneHasIncomingPublicAnnouncement%20PhoneIsLocked%20EthernetUnplugged%20PhoneHasFirmwareUpdate%20FirmwareUpdateFailed%20PhoneWantsToUpdate%20BtoeStateUnpaired%20BtoeStatePairing%20VisionConnectionLost%20PhoneWantsReboot%20PhoneHasDisabledSipStack%20PhoneHasVpnError%20PhoneHasLowMemory%20PhoneRefusedHugeXcapSync%20CurrentIdentityIsNotRegistered%20PhoneIsWaitingForCallCompletion%20CurrentIdentityIsDnd%20CurrentIdentityForewardsWhenBusy%20CurrentIdentityForewardsAfterTimeout%20CurrentIdentityForewardsAlways%20LocationRetrievalFailed%20PhoneWaitsOnNtpServer%20PhoneCannotReachNtpServer%20ActiveLocations%20PhoneHasNoHttpPassword%20PhoneHasNoAdminPassword%20ServerMessageToBeShownDirectly%20CurrentIdentityHasVoiceMessages%20PhoneHasMissedCalls%20CurrentIdentityHasTextMessages%20ExpDeviceCabelingBroken%20ExpDeviceLimitExceeded&store_settings=save

 

But this request either returns "ERR_EMPTY_RESPONSE" when done through my web browsers or using cURL it returns "Unauthorized request". I must be missing something somewhere is my guess.


(Note that for my firmware version I did have to add &store_settings=save according to the SNom Wiki)


Thanks in advance,

Carl

Answer

Hello,


I guess you have to disable the http://wiki.snom.com/wiki/index.php/Settings/restrict_uri_queries setting.


Also another configuration you can apply to skip the requests to provisioning.snom.com is removing the redirection entry from the provisioing_order (http://wiki.snom.com/Settings/provisioning_order).


you can do it in the same way:


"http://phone_IP/settings.htm?settings=save&provisioning_order=pnp:stop dhcp:stop tr69:stop"

Login or Signup to post a comment