How can we help you today?
Start a new topic
Answered

sipgate: Use BLF function keys for transfer

In order to use the BLF presence LEDs, sipgate requires you to configure the function keys as type "Extension". Now, when you enter an extension number (e.g. "11") in the field Number and click on "Apply". The "11" ist automatically converted to a SIP uri (sip:11@sipgate.de;user=phone). This is a problem, though, when a call comes in and you want to transfer it via "*3" (the sipgate code for hold) and then use the BLF key . sipgate expects DTMF tone "11". When you now click on transfer ("#"), it doesn't work ("Transfer failed"). This means you cannot have BLF presence and use those function keys for transfer at the same time. This could easily be solved if it was possible to define different meanings for the function keys when inside a call.


Best Answer

We use this function:


<sip:298@10.1.0.15:5060;user=phone>|*20*


the | gives you the option to pipe the first command to the second.

Maybe it may help you out


4 people have this question

Answer

We use this function:


<sip:298@10.1.0.15:5060;user=phone>|*20*


the | gives you the option to pipe the first command to the second.

Maybe it may help you out

Hello. This is an old article, but still sipgate isn't able to use snom BLF and Transfer through BLF keys.


I found this answer so I try to used in my case the following extension string for internal number 20:


<sip:20@sipgate;user=phone>|*20*


This setting is not stored. No DTMF tone is send during sipgate transfer by pressing the BLF key.

Is it possible to separate the function for BLF LED and BLF Key function?

So it will be possible to see the Light, of phone is in use and by pressing the key it just send DTMF tone "20".


Is there any working solution to transfer sipgate call via sipgate transfer (*3) and pressing a BLF key?


Thank you very much.


Tim

Hi Tim M,


Hello. This is an old article, but still sipgate isn't able to use snom BLF and Transfer through BLF keys.


I'm using sipgate team with "pro" option and snom D785 and of course it does.


I solved it in a comfortable way for me. Now I can transfer a call by pressing one BLF key. Either attended (I wait until the called colleague answers the call and then I hang up) or unattended (by hanging up immediately after pressing the BLF key).


These settings need to be done for the phone settings (regarding mainly the comfortable attended/unattended feature):


<phone-settings>

    ....

    <transfer_on_hangup perm="R">on</transfer_on_hangup>

    <transfer_on_hangup_with_starcode perm="R">on</transfer_on_hangup_with_starcode>

    <transfer_on_hangup_non_pots perm="R">on</transfer_on_hangup_non_pots>

    <attended_transfer_on_ringing perm="R">on</attended_transfer_on_ringing>

    <transfer_dialing_on_transfer perm="R">attended</transfer_dialing_on_transfer>

    <transfer_dialing_on_other perm="R">attended</transfer_dialing_on_other>

    <quick_transfer perm="R">new_call</quick_transfer>

    ....

</phone-settings>


See the docs for detailed information on each setting.


And my function key settings looks like this (for example for BLF key 6):

<functionKeys>

    ...

    <fkey idx="6" context="active" label="John Doe" perm="RW">dest sip:81@sipgate.de;user=phone</fkey>

    ...

</functionKeys>


After configuring this way transferring a call is just one key to press. That's all. No special *x codes to pipe to or any fiddling around with transfer keys and wondering why the call is still on hold...


Bye

Heiko



Hello Heiko Haller,

thank you for your answer.

If I configure your settings, yes I can transfer through BLF key how you discriped.
I don't know if I made a mistake, but in this case snom phone transfer the call by itself.
Transferring process blocks the phone, which transferring the call. So I cannot receive any calls.

Example: 
Extern call calls destination phone (internal number 12).
During phone call I (phone 12) press BLF button to transfer the external call to internal number 20.
During transfer extern caller hear snom music and not sipgate holding pattern music. Destination 20 answer the internal call and Phone 12 hang up.
Destination 20 received the external call.

So far so good. But now nobody could ring phone 12, because it is blocked regarding the call transfer until the transferred call will be finished (BLF key for internal number 12 is ON but phone 12 have been hang up)

Is it the same on your site or is there any mistake in my settings?

Kind regards,
Tim



Hi Tim,


aye, I verified it. The difference is probably: I disabled "busy on busy" in the user's settings (in your case endpoint 12 - in my case: Any endpoint). If disabled the endpoint (12) will be available again after transferring the call. Although the indicator on the BLF shows indeed a red light (for endpoint 12). Maybe I'm able to fix this, too.


I dont't miss the "Busy on busy" since I have corresponding call forwarding in place.


Bye

Heiko


Too bad, sipgate doesn't change the state of the endpoint as ist seems. It's still "CONNECTED" after transferring the call to another endpoint.


Only if one of the other endpoints (either the external caller or the endpoint 20 in the example above) terminates the call, a "terminated" state is send from each internal endpoint (aka 12 and 20) to all subscribers (aka busy lamps for these endpoints) thus turning the corresponding LEDs off.


I dont't know if this is sipgate specific, I can test it with sipgate only. Maybe other SIP providers handle this differently.


See <led_on perm="">... CONNECTED ...</led_on>. If a state is not listed here (or in <led_blink_slow/medium/fast> then the LED is turned off. If a state is not listed in any <led_red/green/orange> but in any <led_on/blink_xxx> then it will lit (blinking or not) in its default color (which depends on the device and on the key/indicator itself). On my D785 the default color for function keys is red. Thus since the state "CONNECTED" is not released for endpoint 12 after transferring the call it will stay lit in a really fine red color.


:(

Heiko

Hi Heiko and all other persons who missing the sipgate transfer function via BLF.


I received the following answer from sipgate:


Nevertheless, you can also do this on your own to give the whole thing more weight. If you would like to submit your feature request to our developers, please do so via


https://feedback.sipgate.de/forums/916930-feature-request


and describe it as precisely as possible. This feature request then goes directly to the product team.


Search for "BLF, Pickup und Verbinden auf eine Taste legen".


Thank you.

Tim

If you would like to submit your feature request to our developers, please do so via I received the following answer from sipgate . Click Speed Test, Mac Auto ClickerAutoclickerCps Test, Roblox Music Codes Thus since the state "CONNECTED" is not released for endpoint 12 after transferring the call it will stay lit in a really fine red colour.

I don't miss the "Busy on busy" since I have corresponding call forwarding in place. If disabled the endpoint (12) will be available again after transferring the call. Daily mail rewards Although the indicator on the BLF show indeed a red light (for endpoint 12). Maybe I'm able to fix this, too.

You just have to transfer it via BLF. After that you can easily solve it. as in Daily Mail Rewards

interesting talk is that you can easil access yur Shala darpan Account on your home check for more detail about Shala Darpan

Login or Signup to post a comment