How can we help you today?
Start a new topic
Answered

D765 - SIP registration prefers IPv4 over IPv6

Hi,


I've just set up one of my new D765 (replacing an existing 370) for the first time and have successfully configured the phone for both IPv4 and IPv6, to connect to my dual-stack IPv4/IPv6 FreeSWITCH server.


When I try to register the phone to my server by entering the domain name of the _sip._tcp.<domain> and/or _sip._udp.<domain> SRV record in the Registrar field of the identity, registration is successful but, although the host name listed in the SRV record to has both valid A and AAAA records, registration does not appear to be attempted via IPv6 and uses IPv4, as if the AAAA record was either never looked up or ignored.  (The FreeSWITCH console confirms that the registration happened via IPv4)


Other clients such as linphone manage to register to the server via IPv6 successfully, so I don't think this is a bug with the FreeSWITCH server.


Best Answer

I do have the same problem with the recent 8.7 firmware on D765.

In addition, snom seems to sometimes prefer the ULA address instead of the public one, which causes trouble.


This is on firmware 8.7.5.28

 

Also putting a DNS name into the Oubound Proxy field on the identity does not cause AAAA records to be used either, and fall back to IPv4 only.  The only way I could get the phone to register using IPv6 was to use an IPv6 address literal.

 

I can confirm this issue for the D365 (don't have the firmware version at hand, but it's the non-UC version that shipped with the phone). IPv6 IP is active and pingable, but phone uses IPv4 only except I use a hostname with AAAA record only. There should be a preference to use IPv6 over IPv4 if IPv6 active or at least a configurable setting to set which is the preferred.


D375 with fw 8.9.3.15 prefers IPv4 over IPv6 if both IPv6 and IPv4 addresses are active and pingable.

Answer

I do have the same problem with the recent 8.7 firmware on D765.

In addition, snom seems to sometimes prefer the ULA address instead of the public one, which causes trouble.

I have the same issue. When using "sipgate.de" as registrar, my Snom D765 with firmware 8.7.5.44 prefers IPv4 although both A and AAAA records are present. When using "v6.sipgate.de" as registrar which is a AAAA-only record, IPv6 works just fine.

Thanks for reporting Marc


I will pass this info internally and get back to you ASAP

The issue still seems to be present with my Snom D765 and the latest firmware 8.9.3.59.102.

Thanks for reporting @Marc

Login or Signup to post a comment