How can we help you today?
Start a new topic
Answered

Firmware Update Error

I was wondering if anyone else was having an issue with trying to update their firmware. I tried both the my companies own web server and the snow update server to no avail.


Basestation M700 and Handset M65


Firmware Update Settings

Firmware update server address: http://dect.snom.com

Firmware path: (empty)
Type: M65

Required Version: 324


Update Base Stations
Update this Base Station only: (selected)

Update all Base Stations

Required Version: 324


This is exactly how it is in the firmware update window, and once i save the parameters and then click start update the LED is supposed to flash on the basestation to indicate that its updating but nothing happens.


Best Answer

Hello Deniz,


please make sure to follow this procedure:


0) Click on the Management link and configure the Syslog Level to Debug

1) verify all the network settings in your DECT base, (IP address, Netmask, Gateway and DNS server)

2) Click on "Firmware Update" link

3) Enter http://dect.snom.com into the Firmware update server address text field

4) Leave the Handsets (M65, M25 or M85) Required Version to 0

5) Click on the Save/Start update button (The first of the two buttons)

6) Under Update Base Stations enter 324 in the Required Version text field

7) Click the Start Update button

8) Click on the Syslog link, at the end you should see some lines like:

 

loc2 .Not   1970-01-01T00:09:16Z 173-[ FWU Downloading File http://dect.snom.com/M700/M700_v0324.fwu] 
loc2 .Not   1970-01-01T00:09:16Z 173-[ Base FWU started] 

 

And your base should start the update process. In case something goes wrong you will see the reason into the log.. 


Deniz,


You can upgrade the M700 and M65 handsets using these attached instructions.



Regards,



Sean Collins

Customer Support Engineer

Snom Technology Inc

docx

Dear Deniz,


just to clarify: the document provided by Sean contains valid instruction on how to update the MXXX using an own local server.


The procedure described in our wiki works with all MXXX devices, in case you have network issue or the device aren't able to access our server dect.snom.com you should use a local server.


Anyway, configuring the log level to "Debug" after submitting the update form you should see all the errors into the system log.

I've followed all the instructions on the doc file but it still won't update. I've turned off my firewall, allowed the folder to be shared and viewed by everyone, and even tried it on multiple computers. Would I be able to do this with the Apple OS X or do i need to do it on windows? Ive tried on windows already with 3 different computers.

Answer

Hello Deniz,


please make sure to follow this procedure:


0) Click on the Management link and configure the Syslog Level to Debug

1) verify all the network settings in your DECT base, (IP address, Netmask, Gateway and DNS server)

2) Click on "Firmware Update" link

3) Enter http://dect.snom.com into the Firmware update server address text field

4) Leave the Handsets (M65, M25 or M85) Required Version to 0

5) Click on the Save/Start update button (The first of the two buttons)

6) Under Update Base Stations enter 324 in the Required Version text field

7) Click the Start Update button

8) Click on the Syslog link, at the end you should see some lines like:

 

loc2 .Not   1970-01-01T00:09:16Z 173-[ FWU Downloading File http://dect.snom.com/M700/M700_v0324.fwu] 
loc2 .Not   1970-01-01T00:09:16Z 173-[ Base FWU started] 

 

And your base should start the update process. In case something goes wrong you will see the reason into the log.. 

I had gotten these messages in the syslog


loc0 .Debug 1970-01-01T00:04:18Z 173-[ DECT:DL_RELEASE_REQ normal Pmid:00001]

loc0 .Debug 1970-01-01T00:04:18Z 173-[ DECT:MAC_DIS_REQ Pmid:00001 Fp:00]

loc7 .Info 1970-01-01T00:04:18Z 173-[ DECT MAC statistics: Pmid:00001 Typ:FN Res:0 Frames:1102,0,0 Bho:0,0 Rssi:57]

loc3 .Debug 1970-01-01T00:04:18Z 173-[ MEDIAMGT: MAC connection disconnected -> Pmid:00001]

loc2 .Debug 1970-01-01T00:04:23Z 173-[ Base FWU failed to start, exit code 2193 (FWUFI_INVALID_IPADDRESS): Invalid IP address]


Ignore it I had updated the firmware, Thank you for your assistance guys!!!!

Login or Signup to post a comment